Svar

YSR-2000 ser stort på DHCP reservation


Omdømme 1
Badge
Hej

Jeg har følgende problem med TV-boksen i mit netværk.
Jeg kører pi.hole som DHCP på en Raspberry og har derigennem reserveret en IP adresse til TV-boksen (192.x.x.100). Men dette ser boksen stort på og tager selv enten 192.x.x.163 eller 192.x.x.232.

Dette irriterer mig til næsten ekstreme grænser, da jeg ønsker at have hvert rum afgrænset med et bestemt IP-scope, f.eks. "Stuen: 192.x.x.100 - 192.x.x.109".

Samme problem gør sig gældende med alle husets Chromecast - men den tager jeg i et andet fora.

Er der andre som har TV-bokse som har præferencer for IP-adresser?

Jeg har prøvet følgende:
  • Indsnævre DHCP scope til én adresse - så kunne boksen slet ikke komme på, til trods for der ikke var andre enheder som havde taget adressen.
  • Slukke helt for boksen, tage kablet ud, vente 1 minut, tænde for boksen og først sætte kablet i da den brokkede sig over manglende netværk.

Forslag til hvordan jeg kan tvinge den til en bestemt IP modtages meget gerne.

/Jacob
icon

Bedste svar af Lindvig 25 marts 2018, 13:05

Fejlen er fundet.... :8 og den lå i de forskellige konfigurationsfiler til DNSmasQ som kører sammen med Pi.Hole.

Når man ligger options ind i et "dhcp-host"-tag så skal man gøre det i ét tag ellers overskriver det sidste tag de forrige....

Alle enheder opfører sig pænt nu.

Se original

3 Kommentarer

Omdømme 4
Badge +1
Virker fint for min ysr-2000
Har lige prøvet at sætte dens mac til en fast ip i min router (Ubiqity Router x)
Skulle bare genstarte den så havde den ny ip

Har ikke prøvet med chromecast, men virker sikkert også

jeg har ikke selv prøvet pihole, men går ud fra det er ligesom alle andre firewalls og man bare sætter en mac adresse til en egen valgt ip adresse

Nu har du vel husket at slå din routers DHCP fra så du kun har een dhcp på netværket ?
Omdømme 1
Badge
....Der er nyt i "sagen" - skriver når jeg har begge hænder fri og er sikker på at fejlen er fundet....
Omdømme 1
Badge
Fejlen er fundet.... :8 og den lå i de forskellige konfigurationsfiler til DNSmasQ som kører sammen med Pi.Hole.

Når man ligger options ind i et "dhcp-host"-tag så skal man gøre det i ét tag ellers overskriver det sidste tag de forrige....

Alle enheder opfører sig pænt nu.

Besvar

    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)