Router doesn't get internet

  • Deltager
  • 1 kommentar
Hi there!

Expat here. I have yousee broadband and it was working flawlessly until two days ago, when my PC marked the network as "no internet". I switched off and on the router and now is stuck with the S led blinking. I've tried giving it more time, resetting with the button underneath and everything I could think of, no clue.

The router is the big white one that looks like a Wii, with the LEDs : phone, Ethernet, @, S and power.

As I can't find any English costumer service... I'm coming here for help!

Thanks in advance

3 Kommentarer

Omdømme 7
Badge +7
Have you checked "driftsinformation" on this site ( You enter your address and the site says, if there is a problem in your area. 

Hi! Didn't know about that page. Just tried, no detected errors, so it must be something else :( . Thanks anyway!
Omdømme 7
Badge +7
It takes a curtain number of customer with similar problems before it gets on "driftsinformation".

Try calling customer service at 70 70 40 40 or contact Yousee on Facebook (if you have accesss). As far as I remember, customer service is outsourced to another firm called Sitel, and some of the people are sitting in a call center in London, so many speak english very well.


    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)