Spørgsmål

Openvpn + Sagemcom 3686 = virker ikke mere


Jeg står i den situation, at jeg fjernadministreret et Yousee netværk bag en Sagemcom 3686 router. For 2 uger siden har OpenVPN kørt upåklageligt. Både udefra og ind, men lige ledes indefra og ud til forskellige VPN server jeg kontrollere.

Men efter en genstart af router og formodentlig en firmware update af TDC, virker det ikke mere.
Indefra kan jeg forbinde til openvpn server (3. stk. brugt i min test), men lader mig ikke browse på internettet.
Det er opsat så klienten diagere al trafik igennem VPN (ingen split-tunnel). Der er dog hul igennem til internettet, idet 8.8.8.8 giver svar tilbage. Men DNS virker ikke og lader mig ikke slå webside adresser op. Der af kan der ikke browses rundt. Det bliver på mystisk vis blokeret i Sagemcomrouteren.

Prøver jeg de selvsamme OpenVPN server med et hotspot på mobilen, som sjovt nok også er Yousee, virker det upåklageligt.

Yousee support yder ikke support og kunne ligeledes ikke give svar på om min box er blevet firmware opdateret. Deres eneste anbefaling er at sætte lid til mere begavet IT-folk herinde. Så det giver jeg et forsøg :D

7 Kommentarer

Omdømme 5
Badge +7
Hej illuanonx

Velkommen på YouSee Forum! :)

Jeg kan se at du ikke har fået svar, og det ærgrer mig da lidt.

Det er ganske rigtigt noget udenfor support-omfang, men vi har en masse dygtige brugere på forummet, som jeg håber kan komme dig til undsætning :)

Hvis du har fået problemet løst, så må meget gerne melde løsningen tilbage og markere denne som "Bedste svar".

God jul :)

Vh.
Omdømme 5
Badge +4
Det lyder som om du ikke har en DNS opslags mulighed. Du skal huske at hvis du kører VPN, skal der fra det netværk du kommer ind på med VPN være en DHCP server der kan tildele f.eks. DNS server. Prøv på en af dem der ikke kan gå ud med DNS navn, hvis det er en Windows maskine, at åbne en CMD (command prompt) og skrive "ipconfig /all" og se efter at der er adgang til DNS server. Hvis du styrer din VPN med statiske IP adresser, så sørg or at der også er DNS server opsat (f.eks. 8.8.8.8 og 8.8.4.4 som er Googel DNS). når du har kontrolleret dette, så prøv at pinge Google.com, eller eb.dk, eller tv2.dk hvis du kan det så virker DNS.
Hej Brian
Jeg køre Gnu/Linux, hvor jeg har prøvet både i config filen at tildele DNS, på selve OpenVPN serveren og manuelt på interfacet. Ifølge ifconfig har den korrekt DNS, men lader ikke til at få lov at slippe igennem tunnelen på TUN interface.

Det der undre mig er at 3 OpenVPN server virker fint med DNS-opslag på min laptop, testet på flere internetforbindelser. Det er blot Yousee's Coax der ikke virker. Mine tanker går på manglende passtrough for OpenVPN i deres Router. Men der er ingen dokumentation på routeren. Hverken igennem Yousee eller Sagemcom.

Mange tak Kasper, men tvivler på det er muligt for hjælp her, da det bunder i manglende dokumentation af Router og Jeres firmwareupdate for 3-4 uger siden. Skulle have anbefalet dem Stofa i stedet, de har kompetente tekniske medarbejder :)
Omdømme 7
Badge +7
Der er mig bekendt ikke passthrough for OpenVPN i routeren (der er dog for andre former af VPN), men du kan prøve at skrue lidt ned for firewallen i den. Der er flere, som har fundet en løsning på den måde. Det er ikke godt, at skue ned på firewallen, men noget kunne tyde baren er sat for højt (f.eks. at alt er ulovligt). Har du prøvet at åbne relevante porte og give protokollen lov? (kan ikke huske om man kan åbne for et protokol nummer i 3686).
Det har virket fint nogle måneder inden firmware updaten fra TDC. Kan dog ikke huske om der var en passthrough for OpenVPN inden. Nu er der IPsec og PPTP. Begge krydset af, men hjælper ikke.

Som default kommer Routeren uden den synlige (webinterface) firewall aktiveret. Jeg har forsøgt igennem flere måneder at få dokumentation på hvad denne firewall gør - men uden held. Som Kasper ovenover nævner, fremhæver Yousee igen at de ikke supportere denne del og der henvises til til producenten Sagemcom som intet har med den custom firmware at gøre. Så desværre ikke noget der kan gøres her. Har forsøgt og løbet direkte ind i muren.

Der er portforwarded korrekt og til specifik offentlig IP adresse. Det eneste jeg kan gøre er næste gang at prøve med Wireshark for at se hvor langt forspørgsel på port 53 kommer. Lige nu prøver jeg at tilgå tilgå udefra. Får fejlen: TLS Error: TLS handshake failed. En typisk besked når Routeren ikke tillader trafikken. SSH/HTTPS virker dog helt fint og bruger jeg nu.
Omdømme 7
Badge +7
Yousee har det desværre med at fjerne funktioner i de routere de udleverer, for at lette supporten af dem. Det gør nok, at mange af os ender med egen router i bridge mode. Jeg bruger selv OpenVPN (udgående) med deres Netgear 6250, og det fungerer fint.
Det er heller ikke med min gode vilje, men supportere for familien og de ønsker ikke en ekstra box stående. Ville aldrig tillade en fremmede teenager mit wifi password, som det er tilfælde Yousee tillader. Supportmedarbejderne har fuld adgang til routeren for at kunne supportere, ensbetydende med de kan se alle passwords og alle sensitive indstillinger: IP, Services, Interne topologi, Alle enheder tilsluttet, navn for enhederne mv. Køre privat min egen cluster-router på replica-san. Kunne aldrig drømme om at give en ISP så vidt kontrol med mit netværk ;)

Men du har nok ret, det er blevet fjernet :|

Besvar

    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)