Spørgsmål

IPv6 Tunnel virker ikke efter at have gået fra DSL til COAX


Har i en længere periode benyttet mig af en IPv6 tunnel fra Hurricane Electric på DSL uden problemer. Men efter at have skiftet til COAX(og samtidigt fået nyt modem), har den ikke virket.

Efter et kig med tcpdump via min router(EdgeRouter Lite) ser det ud til at pakker til IPv6 tunnel bliver sendt, men at der ikke kommer nogen tilbage. Mit umiddelbare gæt er at protocol 41 pakker bliver droppet/filteret af Sagemcom modem.

Andre der har stødt på lignende problemer eller har nogen ideer til hvad der kan være problemet?

Mit udstyr:
Router: EdgeRouter Lite
Modem: Sagemcom Fast 3890(Sat i bridge mode)

8 Kommentarer

Omdømme 5
Badge +4
Hej sequoiia
Hvis du kigger på denne side: https://ipv6-adresse.dk/ kan du se om der understøttes IPv6, men efter hvad der står længere nede (Klippet svar efter spørgsmål om de understøtter IP v6: " YouSee Nej Det er ikke noget vi har planer om på nuværende tidspunkt Tweet 06. jun. 17 " ) Så du skal nok ikke regne med at kunne få IPv6 til at virke foreløbig, men hvis du kigger på samme side er der også
en liste over hvem der understøtter IPv6.

Tilføjelse: Hvis du læser det der står under Hiper, så kan de heller ikke tilbyde IPv6 på Coax. Det tillader teknikken ikke endnu..

Venlig Hilsen

Brian
Hej BrianHHansen,

Jeg taler ikke om native IPv6, men en IPv6 tunnel. Det du har linket har intet at gøre med hvad jeg skriver om. Har i flere år benyttet mig af en IPv6 tunnel igennem TDC / YouSee, blot på DSL. Jeg vil sætte pris på ikke at få et simpelt copy & paste svar så snart man ser ordet "IPv6", og ikke læser hele mit indlæg igennem.
Omdømme 7
Badge +3
Jeg er ikke ekspert på IPv6 så følgende må tages med forbehold.

Hvis den tunnel, du har anvendt virker på samme måde som Microsofts Teredo, så indgår der en portforward for at kommunikationen virker. Netop portforward er noget, det nye Sagemcom 3890 har store problemer med. Men da du kører Sagemcom i bridge mode og bruger egen router, kan problemet ligge både i Sagemcom-routeren og din egen router.

Er UPnP slået til i Sagemcom 3890 og/eller i din egen router?
Er der nogen portforward oprettet i Sagemcom 3890 og/eller i din egen router?

Når det er slået til får jeg automatisk oprettet portforward vedr. Teredo når en PC tilsluttes og genstartes. Har forsøgt med forskellige testmuligheder på internettet, der skulle kunne vise hvor meget der virker vedr. IPv6, men umiddelbart synes ikke noget at virke. Man kan godt pinge en IPv6-adresse og få svar retur (nogen gange). F.eks. har TDC (men ikke YouSee) en IPv6-adresse, som man kan pinge og få svar fra.

PING TDC.DK -6
PING 2a02:108:301:3::10
Det ender hyppigt med timeout, men nogen gange kommer der faktisk svar.

Nu kører du Sagemcom 3890 i bridge mode, og anvender egen router. Det kan nok godt have betydning for om der er en blokering et eller andet sted.
Omdømme 5
Badge +4
Sorry så ikke der stod det lille "tunnel" :) Tilbage til fejlen. Har du set efter om du er bag en enterprise NAT? Altså at din adresse på dit WAN interface er det samme som du viser ude i verden? Det kan godt virke stadig men se denne side: https://help.ubnt.com/hc/en-us/articles/204976104-EdgeRouter-IPv6-Tunnel Det er WAN adressen der skal sættes op, hvis du bruge din edgerouter som IP6 tunnel "generator" :) (God smag i router. har selv en Edgerouter lite, og 2 Edgeswitche derhjemme :) )
@BrianHHansen
Haha, det kan jo ske :) Har tjekket fra min ekstern hosted server, og requests fra mit netværk til den server stemmer overens med den adresse jeg får via DHCP fra mit WAN interface.

@MS-ERIK
UPNP er slået fra i både Sagemcom og min egen router. Har ikke nogen port forward rules oprettet i Sagemcom, men har dog en masse ports forwarded på min egen router, som virker upåklageligt.

Da min IPv6 tunnel virkede med DSL, var det bag double NAT, med UPNP disabled og ikke nogen porte som specfikt var port forwarded i forbindelse med den tunnel. Umiddelbart er de eneste forskelle mellem mit tidligere setup og nuværende er bridge mode og den nye Sagemcom device.

Jeg prøver lige at slå bridge mode fra, så en double NAT situation forekommer igen. Det burde ikke gøre nogen forskel, men så er det hvertfald forsøgt.
Omdømme 7
Badge +3
Efter nogle eksperimenter viser der sig nu en delvis mulighed for kommunikation med IPv6-adresser. UPnP er slået til i ruteren og Googles IPv6-DNS er tastet ind på netkortet (ved ikke helt om det betyder noget, men en test gav flere OK efter dette end før). Bruger et Sagemcom 3890 på YouSees coax-kabelnet.,

Hvad sker der hvis denne adresse bruges i browseren: http://v6.testmyipv6.com/

Jeg får (efter et par forsøg) en grøn boks med teksten:

Excellent!
You are successfully using IPv6 to connect to this server!
Your IPv6 address is
xxxxxxxx [personlig IP-adresse er fjernet her] xxxxxxx

Det må være Teredo-tunnelen, der gør dette muligt selv om YouSee ikke vil indføre IPv6.
Omdømme 7
Badge +7
Hej sequoiia

Jeg håber at du fik det løst :) Meld endelig tilbage og markere gerne bedste svar og giv et like for input i tråden :)
Omdømme 5
Badge +2
Jeg oplever nøjagtig det samme. Mit setup er meget lig dit. Jeg har et Sagem 3890, der er sat i bro tilstand og en PFSense bagved. Fra den ene dag til den næste, stoppede tunnelen med at virke.

TDC havde lavet nogle ændringer og min router genstartede. Jeg kan se det på min overvågning.

Support kan ikke se noget og de yder ikke support, når YouSee routeren er i bro tilstand.