Spørgsmål

Bridge-Mode Guide


I spend 1½ day on this issue including 5 calls to the YouSee support. I’m sharing this solution so that you hopefully don't have to.

I've had a Netgear 6250 COAX modem for multiple years. It has always been running in Bridge-Mode. And it has been running just fine. Bridge-Mode is none-negotiable for me. I have ZyXEL firewall and router connected to the Modem.

In February, I started to get fall-outs. The connection would drop every 2-10 days. Not sure why. I eventually contacted Yousee support and they suggested that I reset the modem. And so I did, upon which an even worse world-of-pain descended upon me.

I never got the Netgear modem up and running again and eventually Yousee swapped it for a SagemCom 3890 modem. I was happy for a short while, until it became clear that I was unable to get this to work either! I couldn't understand why, as this set-up had been working for years.

Eventually I did manage to get things up and running. My resolution was as follows:

1. Reset the modem. Press and hold the small white button for approx. 10 seconds. It’s found on the bottom of SagemCom Modem.

2. Wait for the modem to reboot. It will take a while.

3. Connect a PC to the Modem via Ethernet (probably must be a PC, you’ll see why later). IMPORTANT: Don’t connect anything else to the modem until this guide tells you to!

4. Log-in to the administrative web-console of the Modem using ip: 192.168.0.1. The username is admin and the password is on the paper slip you got with the modem. You still have it, right? If not, call support.

5. Find the setting where you can change from Router-Mode to Bridge-Mode. It’s easy to find if you are just a little bit technical and understand router fundamentals and if you don’t then neither Bridge-Mode nor this guide is for you, in which case call some it guy to help you out.

6. Disconnect the PC. Nothing should be connected to the Modem at this point.

7. Now the Modem will reboot again and now things begin to become interesting…

8. Find the MAC address of the WAN interface on your router (NOT the modem, your router!).

9. Change the MAC-address of the PC you are using, to the MAC-address of your router’s WAN interface – i.e. the MAC-address to noted down in step 8. You might want to note the MAC-address of the PC network card before you change it. You will need to revert the PC network card to its original MAC-address at a later point. If you don’t the PC and the router will no longer get along on your network. (Hint: I tried to change the MAC-address on an Apple Macbook Pro. I failed, which is why I’m using a PC. On a PC, changing the MAC-address was a breeze).

10. Connect the PC to the Modem and open a browser. As you do this, this web-page will likely come up: https://aktiver.mitwifi.dk/. If it doesn’t come up automatically, then browse to it. If you can’t browse to it then this guide will be of no help to you. In that case call support and good luck with that by the way.

11. Follow the simple guide at https://aktiver.mitwifi.dk/

12. Wait for the Modem to reboot. Leave the PC connected!

13. When the modem is running again, your PC should have access to the internet.
Also, note down the ip-address that the PC have now been given.

14. Disconnect the PC. Change back the MAC-address on the PC to its original value. This is important!

15. Connect the router to the Modem. The router will now automatically ask for a WAN ip-address and it should now be given the very same ip-address that the PC have just been given. Why? Because the PC was “impersonating” the router by using its MAC address. This was the trick!

16. You’re done and hopefully your router should work from here on.

You might not need all of this, but I did. If I didn’t impersonate the router on the PC, the PC would be handed the right ip-address, not the router. In fact, the router would try to get an ip-address too, but was given an address in the 10.138.14.0/16 range. However, this other range will not give you access to the internet and you and your router would get stuck in no-mans-land. I tried to explain this to the support to no avail. I could even ping their router at 10.138.14.1 indicating quite clearly that I had a connection all the way to a subnet in their network, but that argument didn’t get me anywhere.

I also tried to initiate https://aktiver.mitwifi.dk/ from the LAN via the router, but that was not possible. The PC had to be directly connected to the modem. Not sure why.

I tried to explain many time to the support that there seemed to be an issue in their end. They were always nice to begin with, but eventually they would fall back to “ohhh but we don’t support bridge-mode so there is nothing else we can do”, which pretty much drove me crazy. It would have expected to get to 2nd level support at that point, but that didn’t happen.

So why did my set-up stop working in the first place? My assessment is two reasons:

1. The Netgear modem broke after years of steady use. When I looked in the log, the log showed log entries from January 1st, 1970??? This seems to indicate that the small battery in the modem keeping the time right at power-lose, had probably stopped working. This was probably also why it has started to fail. But there is no way to be sure.

2. Yousee must have changed their process for handing out ip-address for set-up's using Bridge-Mode. The changes might have been implemented a long time ago, but since my router have not asked for an all new ip-address for a long time, my Netgear router had hummed alone just nicely renewing the already assigned ip-address until the point in time when I reset it and it had to ask for an all-new ip.

I hope this guide will help others.

Good luck!

8 Kommentarer

Omdømme 1
Good you managed to get it working! I just did a similar exercise, although I didn't need to impersonate my router like you did: I changed my Fast3890 modem to bridge mode and set up my (dd-wrt reflashed) Linksys WRT1900ACSv2 as a DHCP client on the WAN side. It then gets a temporary IP address as well as some temporary DNS servers. I enabled DNSmasq on the router, which meant I could connect to aktiver.mitwifi.dk and re-activate the connection from the LAN side on any computer, and after a reboot of the modem, it got the correct IP address and setup (as the router MAC is the one visible to YouSee). Do not try to change your routers MAC to the MAC of the SagemCom modem; it will just confuse the modem, it appears...

However -- and this is the reason I'm writing this -- there are a couple of caveats. It is (sometimes) important to reboot the modem after changing to bridge mode. Otherwise it appears to be doing the right thing, but isn't really and no packages are router through.

Also, you may want to switch off the WiFi in the modem -- I've seen others that claim it still runs even in bridge mode.

And even more importantly: If you don't reset the modem to factory settings, and have used port forwarding rules, you MUST delete all those forwards before you switch to bridge mode. If not, the router appear to be able to connect to any outside services EXCEPT for those where you have had a port mapping. For instance, if you had a local http server on port 80, you absolutely cannot make any connections to outside http services. Ping is fine (unless you remapped that too), and maybe https also works if you didn't have that mapped. In my case, the initial phenomena was that I could connect to some web services, but not all. Turner out to be that https worked fine but not http... and after some hair-pulling, I figured this was caused by the modem still applying the router rules even if the settings panel was no longer accessible!

You can connect to the modem after you've changed the setup via http://192.168.100.1 (usually works fine through your router) and change back to router mode, in case you need to tweak settings (like I had to do)...

This is just (another) error in the SagemCom modem(s). There are at least two other gross ones that I'm aware of (loopback to your own IP stopped working with the May 2017 firmware and also many of them drop small packages routed back to the modem (less than 64 bytes) -- such as ACK packages)... Oh, and the bridge/router state tables also sometimes run full and cause more dropped packages and connections, so it's a good idea to reboot the modem at least once every month :-) Other than that, they run fine!

Final comment: Your login and password is also written on a label at the bottom of the modem (unless you've changed it to something else).
Det lykkedes mig ved at følge:
https://forum.yousee.dk/coax-9/mystik-med-wan-ip-adresser-5336/index1.html#post118952

Men mange tak til jasperhb og pnomandk for deres udførlige kommentarer. Sætter virkelig pris på dem, og selvom jeg endte me at bruge en anden metode var jeres posts en kæmpe kæmpe hjælp for mig, så jeg kun regne ud hvad og hvorfor.
Nu har jeg prøvet adskillige guides (alle tre ovenstående) samt ringet til support. Og jeg har prøvet at clone Sagemcom-MAC ind på min router og diverse andet, men hver gang jeg sætter den i bridge mode og prøver at tilgå nettet fra min Netgear R6400, så går den i loop på aktiveringsportalen.

Så der var to muligheder: Enten at sætte min netgear i AP mode, men så kunne den ikke lave QoS - eller gøre nedenstående. Det er ikke helt bridgemode, men det er tæt på og fungerer fint...

1. Sæt din egen router i Lanport 1 på Sagemcom
2. Log ind på Sagemcom, se hvilken IP den bliver tildelt.
3. Log ind på din egen router og tildel den statisk IP - samme IP som Sagemcom lige har tildelt
4. Find på Sagemcom punktet "DHCP IP Address Lease Reservations" under DHCP, og lås din routers IP ved at tilføje MAC.
5. Slå DHCP fra på Sagemcom
6. Slå WiFI fra på Sagemcom
7. Find punktet DMZ på Sagemcom, og lad det pege på din routers faste IP.
8. Husk at slette evt. "Forwarding" rules på Sagemcom, efter du har lavet DMZ.

Nu burde ingen kunne koble sig på Sagemcom via WiFi, og din egen router får alt trafik grundet DMZ. Samtidig er det din egen router som klarer alt DHCP.
Det KAN være at der er et problem med dobbelt-NAT, men det har ikke givet anledning til problemer i mit setup. Husk også at alle kabel-forbindelser udover din router, skal sidde i din egen router og ikke i Sagemcom, da du jo netop har slukket for DHCP.

Grunden til at jeg gjorde ovenstående, var at Sagemcom ikke kunne klare de 12 devices som en familie på 5 har - og slet ikke hvis der blev streamet Netflix og Youtube på samme tid, så kunne far og mor ikke også læse mails på samme. Det funker nu - og vi er glade for vores Netgear R6400 (havde tidligere en TP-Link C9, den var vi ikke så glade for)

Håber det kunne hjælpe nogen derude :-)
Dear all,
Thank you for the post and details... I spent the night plugging / unplugging / rebooting my Netgear 6250 & Apple Airport Extreme, tried different settings but without success. For sure the Netgear is setup in Bridge Mode but when the message box pops-up for the activation, I'm stuck. Pressed OK twice but it's a loop, nothing behind, when the expected message is to be ' success '...
Will give one more try, following your step-by-step tutorial.
Tak ;-)
Cédric
jasperhb's guide did the trick for me.

Thank you jasperhb.

Regards
/Nikolaj
Argh!

It just won't work. First of all I don't any computer with an ethernetport (long live wireless).

Hopefully, some could give me an idea what to do next.

Trying to connect a Asus N66AC as router and disabling my YouSee Netgear C6250.

I can disable the router-mode on the Netgear and enable router-mode on my Asus. This seems to work. I get to the activation page on YouSee when connecting to the wireless network (broadcasted by the Asus router).

However, this is where I get into problems. I can continue from the first page, but the next page now tells me that

Signalet i dit kabel-tv-stik er ikke tilstrækkelig stærkt.

"Tilslut kabelmodemmet til første stik i din bolig - dvs. der hvor kabel-tv-signalet kommer ind.
......
...."

Basically, that there is not high enough signal strength for getting a internet connection. The Netgear was not moved. Setting it back into router-mode make everything work (but you don't want two routers so for now the Asus is in Access point mode).

I tried leaving both turned off for 15 minutes to make sure whatever ip/lease has expired (I would think at least). Do I really need to clone MAC-adresses for this?!

Ideas?

PS: I kan godt svare på dansk, det var mest af hensyn til trådstarter.
Det der gjorde udfaldet for mig var trin 6 "Disconnect the PC. Nothing should be connected to the Modem at this point.".
Dantzig skrev:

Argh!

It just won't work. First of all I don't any computer with an ethernetport (long live wireless).

Hopefully, some could give me an idea what to do next.

Trying to connect a Asus N66AC as router and disabling my YouSee Netgear C6250.

I can disable the router-mode on the Netgear and enable router-mode on my Asus. This seems to work. I get to the activation page on YouSee when connecting to the wireless network (broadcasted by the Asus router).

However, this is where I get into problems. I can continue from the first page, but the next page now tells me that

Signalet i dit kabel-tv-stik er ikke tilstrækkelig stærkt.

"Tilslut kabelmodemmet til første stik i din bolig - dvs. der hvor kabel-tv-signalet kommer ind.
......
...."

Basically, that there is not high enough signal strength for getting a internet connection. The Netgear was not moved. Setting it back into router-mode make everything work (but you don't want two routers so for now the Asus is in Access point mode).

I tried leaving both turned off for 15 minutes to make sure whatever ip/lease has expired (I would think at least). Do I really need to clone MAC-adresses for this?!

Ideas?

PS: I kan godt svare på dansk, det var mest af hensyn til trådstarter.



Hmm selvom det bare er Netgear routeren der er sat til får jeg det samme at vide om signal styrken

Besvar

    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)