SAGEM 3890 ingorerer svar fra egen "bind" DNS server | YouSee Community
Spørgsmål

SAGEM 3890 ingorerer svar fra egen "bind" DNS server


Hvorfor er Sagem holdt op med at sætte min lokale DNS server ind i DHCP record den giver til klienter? Aarrhhh...

Jeg skal bruge min egen DNS server som beskrevet nedenfor under “Hvorfor egen DNS” - på grund af en anden bug i Sagem.

Det har tidligere virket fint at sætte min egen BIND DNS server op og så konfigurere  min egen DNS server under “Basic → DHCP → DNS Server Configuration”. Indtil for ca. 6 måneder siden (jeg ved sgu ikke præcis hvornår det holdt op med at virke). Jeg er ret sikker på at i fortiden, når man havde konfigureret under DHCP at den skulle bruge en bestemt DNS server, så konfigurerede DHCP klienterne med den IP addresse som DNS server, sådan at klienter tilgik denne DNS server direkte. Det gør den ikke længere. Den konfigurerer Sagem’s egen IP addresse som DNS server, der nu fungerer som DNS forwarder og laver så selv DNS opslagene i den konfigurerede DNS server og returnerer svarene til klienten.

Jeg kan se med “wireshark” at DNS forespørgsler fra klienter faktisk kommer ind til min DNS server fra Sagem’s IP addresse, og at svar bliver sendt tilbage. Når min egen BIND virker som DNS forwarder og bare forwarder svar fra googles 8.8.8.8 DNS server (99% af tiden), så virker alt fint. Men når det er svar der er lokalt konfigureret i min egen BIND server, så bliver de sendt til Sagem men totalt ignoreret af Sagem’s DNS forwarder og bliver ikke sendt tilbage til klienten. Jeg ved ikke hvorfor. Hvis jeg manuelt konfigurerer en klient til at bruge min egen DNS server direkte - som i fortiden - og ikke gå via Sagem-en virker alt fint.

Og dette setup har altså virket indtil for ca. 6 måneder siden.

Og før nogen svarer at problemet nok er med BIND vil jeg minde lige om at BIND er den mest udbredte DNS server overhovedet: https://en.wikipedia.org/wiki/BIND og at dette har virket fint i fortiden her.

Hvorfor egen DNS?

Jeg har min egen server stående herhjemme. Den skal have et hostnavn, f.eks. minserver.morch.com. Det allerletteste ville jo være bare at lægge min offentlige IP addresse ind i DNS for minserver.morch.com. Men inde fra mit eget netværk kan man ikke tilgå den offentlige IP addresse. Dette er fordi Sagem 3890 har en bug der gør at den ikke understøtter “Hairpin NAT” også kendt som “NAT Loopback” ( https://en.wikipedia.org/wiki/Hairpinning ) og derfor er jeg nødt til at have min egen DNS server, sådan at ude i verden siger DNS at minserver.morch.com har min offentlige IP adresse, mens herhjemme indenfor mit eget netværk er DNS nødt til at svare med den interne addresse. For ellers kan jeg ikke tilgå minserver.morch.com både inden i huset og ude i verden. Jeg har apps på klienterne som jeg ikke vil ændre afhængigt af om jeg er på mit interne netværk eller på netværk udenfor hjemmet.


2 Kommentarer

Og jeg besvarer lige mit eget spørgsmål:

Ovenfor har jeg nu dokumenteret at dette er en Sagem bug (Sagem ignorerer svar fra min BIND server), som jeg er stødt på mens jeg arbejder uden om en anden Sagem bug (Sagem understøtter ikke  “Hairpin NAT”). Jeg sender gerne wireshark .pcap filer hvis nogen tvivler på mine findings.

For at arbejde uden om dette har jeg helt disablet DHCP serveren i Sagem. I stedet har jeg enablet en DHCP server i min Synology NAS. Den sender (som Sagem også burde) min interne DNS server adresse i DHCP recorden til klienter, så de bruger denne DNS server direkte. Og alle klienterne (Windows PCer, Android telefoner, Linux server og Apple iOS telefoner) kan godt snakke med min BIND server.

Dette en workaround der gør at det “virker” for mig. Men det fikser ikke Sagem problemet for andre.

 

Omdømme 5
Badge +1

Hej Peter 

jeg har nøjagtig samme udfordring som du har 

jeg har derfor også min egen interne dns server. Og interne dhcp server som konfigurerer alle klienter til at benytte min interne dns. Derudover har jeg sat dns forwarding op på den interne dns server. På sagem router har jeg naturligvis disabled dhcp serveren. Derudover kører jeg i bridge mode og benytter egen pfsense router, så man slipper for bugs og begrænsninger i sagem router 

Besvar